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1  Introduction
1.1  Purpose and target audience

1  Introduction

1.1  Purpose and target audience
This document explains the functions and usage of the integration between Dassault Systèmes
SOLIDWORKS Electrical and Dassault Systèmes SOLIDWORKS PDM Professional. The document is written for
end users who work with the integration daily.

How to read this document
This document is structured chronologically and you should read it in the order of the chapters described. If
you skip chapters, you will miss important information.

Where appropriate, cross-references to other chapters are listed. To quickly return to where you came from
aer clicking such a link, click the Back button in your PDF viewer. Try it right now with this link!

Notes used
This note highlights additional information about the current content.

This note highlights important instructions.

1.2  Functional overview
The integration connects SOLIDWORKS Electrical with SOLIDWORKS PDM and allows managing electrical
engineering information in a central place.

Functions in the SOLIDWORKS PDM menu
The installer creates the integration menu SOLIDWORKS PDM in the SOLIDWORKS Electrical ribbon bar.

Function Title Description

Open
Opens a SOLIDWORKS Electrical project from the local SOLIDWORKS
PDM vault.

Check Out
Reserves SOLIDWORKS Electrical project file(s) in SOLIDWORKS PDM
for the current user.

Undo Check Out
Removes the reservation for the SOLIDWORKS Electrical project file(s)
and the current user in SOLIDWORKS PDM.

Check In
Stores the SOLIDWORKS Electrical project file(s) in the local
SOLIDWORKS PDM vault.

Get Latest
Version

Updates the current SOLIDWORKS Electrical project with the latest
version stored in SOLIDWORKS PDM.

Get Version
Updates the current SOLIDWORKS Electrical project with a specific
version stored in SOLIDWORKS PDM.

Search
Opens a search dialog to search for objects in the local SOLIDWORKS
PDM vault.
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1  Introduction
1.3  Starting the integration

Function Title Description

Show
Opens the location of the SOLIDWORKS Electrical project in the local
SOLIDWORKS PDM vault.

Show Card
Opens the data card for the SOLIDWORKS Electrical project folder and
container.

Change State
Pushes the SOLIDWORKS Electrical project through a workflow in
SOLIDWORKS PDM.

Synchronize
Libraries

Creates new virtual documents for SOLIDWORKS Electrical
manufacturer parts and cables in SOLIDWORKS PDM and synchronizes
the attributes in both systems.

Select Vault
Opens a dialog to select a SOLIDWORKS PDM vault to be used in the
integration.

1.3  Starting the integration
The integration operations can be started from the SOLIDWORKS Electrical ribbon bar. Some operations are
also accessible from the pop-up menu in the SOLIDWORKS PDM vault view.

Specify the vault
If you have several SOLIDWORKS PDM vaults configured and want to start working with the integration,
select a vault to use first (see Select Vault (p. 22)).

Start the integration
The progress dialog appears when the integration starts. The dialog shows the name of the integration
module, the currently executed action and the progress.

Clicking the button Cancel stops the operation. If the current step can not be stopped right now, the button
shows Waiting instead and the process is stopped when possible.
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1  Introduction
1.4  About data storage in SOLIDWORKS PDM

Integration dialogs and messages are sometimes hidden by a SOLIDWORKS Electrical window. If the
integration does not respond, check for open dialogs in the background.

1.4  About data storage in SOLIDWORKS PDM
The integration stores the SOLIDWORKS Electrical project with the data for manufacturing, purchasing and
assembly of electrical designs in SOLIDWORKS PDM.

The integration creates a folder for the project in the local SOLIDWORKS PDM vault. The name of the folder
can be configured, see SSA Tool > File Structure > Folders > SOLIDWORKS Electrical Project > Name
Rule. Properties of the project are synchronized with the SOLIDWORKS PDM folder attributes. The project
folder contains the project container file (.tewzip), and extracted files which are stored in subfolders with
configurable names.

All extracted files are linked as SOLIDWORKS PDM custom references to the project container file.

The local SOLIDWORKS PDM vault can store the following information:

Project container files

Project containers contain a complete snapshot of the project files and database. Project containers have
the extension .tewzip.

Drawing sets in DWG or DXF format

Drawing sheets in an electrical project can be exported to the DWG or DXF format. This format can be
used for sharing schematic content with all collaborators who do not have access to SOLIDWORKS
Electrical.

Intelligent PDF files

An intelligent PDF file contains all reports and drawings in the project. Additionally there are component
and document tree bookmarks that reflect the SOLIDWORKS Electrical data structure. The integration
supports two PDF creation modes:

■ One PDF for all reports and drawings

■ One PDF for each document book

The PDF creation modes can be configured, see SSA Tool > General Settings > Project export settings >
PDF per book.

Assemblies and BOMs

For each location found in the project, a virtual document with extension .swe.cvd is created in the
project folder. Assemblies in SOLIDWORKS PDM contain BOMs as set of links to manufacturer parts and
cables. Only such manufacturer parts and cables that are synchronized with the function Synchronize
Libraries in SOLIDWORKS PDM, can be added to the BOM in the SOLIDWORKS PDM assembly.

Other project-related files

An electrical project can contain a variety of supplementary files such as design documents, reports and
screenshots. Extracts of such files can also be configured in the SSA Tool.
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1  Introduction
1.5  Manufacturer parts and cable references

1.5  Manufacturer parts and cable references
Manufacturer parts and cable references are stored in the local SOLIDWORKS PDM vault as virtual
documents.

Properties of manufacturer parts and cable references are synchronized with the document attributes
in SOLIDWORKS PDM. The mapping of properties and attributes can be configured, see SSA Tool > File
Structure > File > Purchased Part / Purchased Cable.

The files with the manufacturer parts and cable references are located in the library folder in the
SOLIDWORKS PDM vault. The name of the library folder can be configured, see SSA Tool > General Settings
> Library Synchronization > Library Folder.

1.6  Logs and support
Integration can create log file during execution.

If logging is turned on, during the execution integration produce log file. By default logging is turned off. To
change the logging settings, please edit %XPlmRootDir%\xml\PDMPConnector.xml file. This file will be
created aer the installation.

Configuration parameters

Parameter name Description

EnablePDMPLogging Turn on\off logging. Possible values: true or false.

PDMPLogFile
Full path to the log file location (for example C:
\pdm_integration.log).

PDMPLogLevel

Integer value, specifying how detailed the logging should be. Can
be any integer from 1 to 100, where 1 - only critical messages will be
logged, 100 - all messages will be logged. Support will always ask for
'Debug' log, please set this value to 100 in this case.

Log file is never deleted or cleaned up by the integration and can grow quite big if logging will be
turned on for a long time. Best practice would be to turn it on only for creation of 'Debug' log when
contacting support.
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2  Usage
2.1  Open

2  Usage

2.1  Open
Opens a SOLIDWORKS Electrical project from the local SOLIDWORKS PDM vault.

Navigate to the project folder, select a project container with ending .tewzip and click Open.

If the project already exists in the project directory, it is updated with the latest version in SOLIDWORKS
PDM.

The project is overwritten as a result of this operation. Observe the warning message.
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2  Usage
2.2  Check out

2.2  Check out
Reserves SOLIDWORKS Electrical project file(s) in SOLIDWORKS PDM for the current user.

Select the project files to reserve for the current user and click Check Out.

The project container must not be checked out in SOLIDWORKS PDM.
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2  Usage
2.3  Undo Check Out

2.3  Undo Check Out
Removes the reservation for the SOLIDWORKS Electrical project file(s) and the current user in SOLIDWORKS
PDM.

Select the project files from which the reservation for the current user should be removed and click Undo
Check Out.

The project container must be checked out by the current user in SOLIDWORKS PDM.

Undo Check Out updates the project with the latest version in SOLIDWORKS PDM.

The project is overwritten as a result of this operation. Observe the warning message.
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2  Usage
2.4  Check In

2.4  Check In
Stores the SOLIDWORKS Electrical project file(s) in the local SOLIDWORKS PDM vault.

Select the parent folder in which the project data is created and click OK.

If the setting Default Root Folder is defined in the SSA Tool, this folder is pre-selected in this dialog.

The folder selection dialog may not appear if the Always use default root folder option in the
configuration is set. In this case, the root folder defined by the integration administrator will be used.

The first step of the process opens the dialog Add Files. Select the project file(s) to add to the local
SOLIDWORKS PDM vault and click Add.
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2  Usage
2.4  Check In

The second step opens the dialog Check In Files. Select the project file(s) to check in into SOLIDWORKS PDM
and click Check In.

Enable the option Remove Local Copy for the project container file (*.tewzip) to delete the project from
SOLIDWORKS Electrical. Aer that, the project will remain in the vault as an archive only. To start working
with the project again, use Open (p. 10).

In the case when option Remove project from SW Electrical aer check in is set in the
Administration tool, project will be deleted in any case.

Enable the option Keep Checked Out to keep the project file(s) checked out by the current user.

If the project contains parts which are not yet synchronized with SOLIDWORKS PDM, a warning message is
displayed showing a list of missing parts and their marks.

The list of missing parts is stored in the local folder of the current user and is used during the next
execution of Synchronize Libraries.

2.4.1  BOM handling
During Check In, the integration creates BOM header documents in SOLIDWORKS PDM and links library parts
(also represented by virtual documents) to this BOM header document.

There are three possible scenarios of how BOM headers are organized:

■ By Location - each project location will have a corresponding BOM header with a list of parts and cables
used.

■ By Component Type - three BOM headers will be created: for parts, cables and harnesses.

■ One Global - one BOM header, containing all parts and cables will be created.

BOM headers are represented in SOLIDWORKS PDM as virtual documents with the extension .swebom.cvd.

To find which parts are used in a BOM header, click on the file and select the tab Contains or Bills Of
Materials.
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2  Usage
2.4  Check In

Before starting Check In, it is recommended to run Synchronize Libraries (p. 19) first. Aer that
select Process > Management > Update Data and follow the instructions. This ensures that part
properties in the project are updated with the current attribute values from SOLIDWORKS PDM.

2.4.2  3D handling
During Check In, the integration creates links in SOLIDWORKS PDM between the documents representing
the project and locations, and corresponding 3D assemblies.

Select Process > SOLIDWORKS assembly > Select existing file and assign the project and locations in the
dialog.
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2  Usage
2.5  Get Latest Version

3D assemblies must reside in the SOLIDWORKS PDM vault. Links to assemblies located outside of the
vault are ignored.

During Check In, the link between the tewzip file and the 3D-assembly file assigned to the project is set. If
locations also have assigned assemblies, they are also linked.

Locations are processed only if the BOM mode By Location is used.

Related links
3D parts handling (p. 20)

2.5  Get Latest Version
Updates the current SOLIDWORKS Electrical project with the latest version stored in SOLIDWORKS PDM.

Select the project file before executing the function.

The project is overwritten as a result of this operation. Observe warning message.

2.6  Get Version
Updates the current SOLIDWORKS Electrical project with a specific version stored in SOLIDWORKS PDM.

Select a specific version to download and open.
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2  Usage
2.7  Search

The project is overwritten as a result of this operation. Pay attention to the warning message shown.

2.7  Search
Opens a search dialog to search for objects in the local SOLIDWORKS PDM vault.

Access the SOLIDWORKS PDM search functionality quickly from within SOLIDWORKS Electrical.

2.8  Show
Opens the location of the SOLIDWORKS Electrical project in the local SOLIDWORKS PDM vault.

Make sure the project is open in SOLIDWORKS Electrical, checked in into SOLIDWORKS PDM and set to
Current.

If the project container file is already available in SOLIDWORKS PDM, Show opens the current project folder
and selects the project container file.

If the project is stored in SOLIDWORKS PDM but the project container file hasn't been checked in yet, Show
opens the root folder and selects the current project folder.

2.9  Show Card
Opens the data card for the SOLIDWORKS Electrical project folder and container.

The Data Card dialog contains three sections:

■ A header section with information about the project container state

■ A tab with the Project Folder data card

■ A tab with the Project Container data card
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2  Usage
2.9  Show Card

■ SWE Version: Shows the SOLIDWORKS PDM version of the project container opened in SOLIDWORKS
Electrical. It may differ from the latest version in SOLIDWORKS PDM.

■ Local Vault Version: Shows the version of the project container in the local SOLIDWORKS PDM vault and
the current version in the SOLIDWORKS PDMPDM vault on the server.

■ Project Folder: The data card can be edited by clicking the tab Edit Values.

■ Project Container: If the project container is checked out by the current user, it is also possible to edit
this data card.

■ OK: Saves changes to SOLIDWORKS PDM.

■ Cancel: Closes the dialog without saving.

Make sure the project is open in SOLIDWORKS Electrical, checked in into SOLIDWORKS PDM and set to
Current.
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2  Usage
2.10  Change State

2.10  Change State
Pushes the SOLIDWORKS Electrical project through a workflow in SOLIDWORKS PDM.

Make sure the project container is checked in.

Select a workflow state first. Only allowed states are shown in the list.

The transition dialog appears in which the project files suitable for transition are shown.

Enable the option Change State for the files to be changed.

2.11  Synchronize Libraries
Creates new virtual documents for SOLIDWORKS Electrical manufacturer parts and cables in SOLIDWORKS
PDM and synchronizes the attributes in both systems.

Manufacturer parts and cables without a corresponding virtual document in SOLIDWORKS PDM are
considered missing during Check In and are not included in the BOM.

The library is stored in the configured folder in SOLIDWORKS PDM, see SSA Tool > General Settings >
Library Folder.
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2  Usage
2.11  Synchronize Libraries

Synchronization is performed in batch mode and can take some time depending on the library size.

Library synchronization can be executed without user interaction, to be run overnight. To do this start
connector_runner.exe from installation directory.

Aer synchronization, the changes to the library have to be updated in the project, otherwise they
will not appear in the schematics. Select Process > Management > Update Data and follow the
instructions.

2.11.1  3D parts handling
During Synchronize Libraries, the integration creates links between the virtual documents representing the
electrical parts and their 3D models.

Prerequisites:

■ 3D parts storage in SOLIDWORKS Electrical is pointing to a location inside the vault ( Tools > Application
Settings > 3D > 3D parts folder) and the 3D representations of parts are placed within this location.

■ The setting Copy 3D parts to project is switched off (Tools > Application Settings > 3D > Copy 3D parts
to project).

As a result of Synchronize Libraries, documents representing the electrical parts in the SOLIDWORKS
Electrical library which are assigned to 3D models, will be linked in the vault to the corresponding 3D files.

SOLIDWORKS Electrical view:
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2  Usage
2.11  Synchronize Libraries

SOLIDWORKS PDM view:

Related links
3D handling (p. 15)
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2  Usage
2.12  Select Vault

2.12  Select Vault
Opens a dialog to select a SOLIDWORKS PDM vault to be used in the integration

If you have only one SOLIDWORKS PDM vault configured, you can skip the Select Vault operation and
the vault will be selected automatically.

2.13  Special notes
Additional information when duplicating a project.

Copy project in SOLIDWORKS Electrical
In SOLIDWORKS Electrical, it is possible to copy a project. If the original project was stored in SOLIDWORKS
PDM via Check In, the copied version will also create a new SOLIDWORKS PDM folder upon Check In.

Copy project in SOLIDWORKS PDM
If a project was copied in SOLIDWORKS PDM, the integration will detect this and will unlink it from the old
location upon Open.

The suggested way to copy a project in SOLIDWORKS PDM is to copy the project container file
(.tewzip) only and to leave the other project files such as drawings, PDF files, etc. untouched. Having
such files in the new, copied project folder will cause naming conflicts upon Check In.

2.14  Using vault pop-up menu
You can perform some of the integration operations directly from the SOLIDWORKS PDM view.

In the vault view , right-mouse click on the project container archive (*.tewzip) and select an operation
from the pop-up menu:
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2  Usage
2.14  Using vault pop-up menu

Description of operations
Table 1:

Operation name Description

Edit in SOLIDWORKS Electrical
Opens the selected project archive in SOLIDWORKS
Electrical (see Open (p. 10)) and checks out the
project container.

Open in SOLIDWORKS Electrical
Works the same as Edit, but doesn't check out the
project container.

The integration and SOLIDWORKS Electrical must be installed to perform these operations.

Sometimes the progress dialog of an operation does not appear on top of other windows. Check the
taskbar to bring up the window.
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3  Troubleshooting
3.1  Integration does not respond

3  Troubleshooting

3.1  Integration does not respond
If the integration does not respond, check for open dialogs in the background. Integration dialogs and
messages are sometimes hidden by a SOLIDWORKS Electrical window.

3.2  Function is not working
If a function from within the SOLIDWORKS PDM toolbar is not working, restart SOLIDWORKS Electrical and
try again.

If this does not help, set the logging level to All, retry the action and retrieve the log files from the configured
destination directory. Then zip the log files and send them to the XPLM support for analysis.

3.3  Check-in operation fails when exporting data
If the check in process in the step "Exporting Data from SWE" fails, make sure the PDFCreator utility is
installed. Without the utility, SOLIDWORKS Electrical cannot export project data correctly, so that the
integration cannot add files to the vault.
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